Jump to content
support

Troubleshooting Browser Based Remote Session Launcher

Recommended Posts

The Browser Based Remote Session Launcher that was introduced in Build 8275 requires some installation and configuration to be applied to your Passwordstate web server, but if you find you cannot launch session for any reason, please run through these troubleshooting steps below to resolve the problem:

 

Issue 1:

Do you see the Passwordstate-Gateway Service running on your web server?  If not then please follow the documentation under Help -> User Manual -> KB Articles -> Configure Browser Based Remote Session Launcher to set up this feature as a once off process

 

Issue 2:

The Passwordstate-Gateway service is running but connections won't launch, you should be presented with a page of troubleshooting steps.  Try clicking the "Test SSL Certificate" link on this page and see what results that gives you.  If you get results saying your certificate is not secure, take the necessary steps to ensure your browser trusts your Passwordstate certificate.  This could be installing the certificate into the Trusted Certificate Authorities on your desktop though Internet Explorer, or adding an exception in Firefox as an example.

2018-03-20_10-12-03.png

 

Issue 3:

If you receive a Web Proxy Gateway error like the screenshot above in Issue 2, this might be caused by a firewall on your web server blocking the connection.  To fix this, log into your web server and run he following command in elevated Command Prompt to create a firewall rule:

 

netsh.exe advfirewall firewall add rule name="Passwordstate-Gateway" dir=in action=allow protocol=TCP localport=7273

 

Issue 4:

If you receive a Web Proxy error like the screenshot above in Issue #2, this may be caused by incorrect syntax in your gateway.conf file.  Please ensure the syntax of this section of the gateway.conf file is in the same format as the below screenshot

2018-10-02_11-07-02.png

Issue 5:

Can you successfully start the Passwordstate-Gateway service on your web server?  If not, please try these suggestions:

 

Suggestion 1:

Check the name of the C:\inetpub\Passwordstate\hosts\gateway\Passwordstate.pfx file is correct. This file must be called 'Passwordstate.pfx' for the service to work correctly

 

Suggestion 2:

Did you install Oracle JRE on your web server?  If not please refer to Help -> User Manual -> KB Articles -> Configure Browser Based Remote Session Launcher to install Oracle, and also complete the set up process

 

Suggestion 3:

Did you configure the SSL Certificate for the gateway, and put the encrypted password for this certificate in the gateway.conf file?  If not please refer to Help -> User Manual -> KB Articles -> Configure Browser Based Remote Session Launcher which describes how to export your Passwordstate certificate, and apply it to you Gateway service

2.png

 

Suggestion 4:

Is the default port of 7273 is in use by something else?  To test this, run a command prompt on your web server, and run the following command:

 

netstat -ano | findstr :7273

 

You should get a blank result back from this command if the port is free.  If something else is using the port, try changing the listening port in the C:\inetpub\Passwordstate\hosts\gateway\gateway.conf file to something else under 10000, save and restart the service

 

Suggestion 5:

Check the password that you set when exporting the certificate is the same password that you have encrypted and applied to your C:\inetpub\Passwordstate\hosts\gateway\gateway.conf file.  One way to test this is to export the certificate again from IIS, and set a new password.  Update the password in the Gateway.conf file and see if the service starts then

 

Suggestion 6:

In the Gateway.conf file, update SSL to false, and save the file.  Try restarting the service again now, and if it starts, this confirms that the certificate is the issue. And you should try running through the export process again and confirm everything is configured according to the documentation under Help -> User Manual -> KB Articles -> Configure Browser Based Remote Session Launcher

 

2018-10-02_11-09-14.png

 

Suggestion 7:

Possibly the recording path that is set in the Gateway.conf file does not exist or is incorrect.  Try changing the recording path back to the default location which is shown in the screenshot below, and then try starting the service again"

 

2018-10-02_11-13-42.png

 

 

 

 

 

 

 

 

Installation Video of installing the Gateway can be found below, which outlines all steps to set this up on your web server:

 

 

We hope this helps and please log a support call with support@clickstudios.com.au if you are still having difficulty getting the Browser Based Remote Session Launcher to work correctly.

 

Regards,

Support.

 

1.png

Share this post


Link to post
Share on other sites

Hello,

 

I have walked through each of the troubleshooting steps.

Nothing mentioned above has resolved the issue.

Certificate is loaded, service is running, port is listening, etc.

 

When attempting to launch a session from multiple different browsers and are displayed with "Please wait while connecting..." indefinitely.

 

What is the next step to troubleshoot?

 

Thank you!

 

image.png.4dd5d03cb8ba595c751dea2fbeb7aea4.png

Share this post


Link to post
Share on other sites

Hello,

 

Sorry you're having some issues, and can you confirm a few more things for us:

  • What Build of Passwordstate are you using
  • What Browser Type are you using
  • Is your Passwordstate-Gateway Windows Service started
  • What sort of certificate did you export to use with the Gateway - is it a trusted certificate, or is it a self-Signed certificate
  • With the URL you're using for Passwordstate, is the DNS entry for this from internal DNS, or external? If external, you may need to open access on your firewall to get to the Gateway's default port which is 7273
  • If you go to the screen Administration -> Remote Session Management and click on the 'Browser Based Gateway Settings' button, if there is a URL specified in the 'Gateway URL' field, please clear this, Save the change, and then test again
  • From your Passwordstate web server, do you have network connectivity to the Host? You can run the following PowerShell command to determine this (change host name and port as appropriate) - test-netconnection hostname.domain.com -port 3389
  • Do you have any firewalls enabled on your Passwordstate web server? If so, you may need to allow access on Port 7273

 

Regards

Click Studios

Share this post


Link to post
Share on other sites

Hello,

 

Thank you for your response. Answers to your questions follow:

 

  • What Build of Passwordstate are you using
    • 8679
  • What Browser Type are you using
    • Firefox
    • Chrome
    • Brave
    • Internet Explorer
  • Is your Passwordstate-Gateway Windows Service started
    • Yes
  • What sort of certificate did you export to use with the Gateway - is it a trusted certificate, or is it a self-Signed certificate
    • Publicly trusted certificate from GoDaddy
  • With the URL you're using for Passwordstate, is the DNS entry for this from internal DNS, or external? If external, you may need to open access on your firewall to get to the Gateway's default port which is 7273
    • Internal address is resolvable. Same as primary Passwordstate URL.
  • If you go to the screen Administration -> Remote Session Management and click on the 'Browser Based Gateway Settings' button, if there is a URL specified in the 'Gateway URL' field, please clear this, Save the change, and then test again
    • This is cleared.
  • From your Passwordstate web server, do you have network connectivity to the Host? You can run the following PowerShell command to determine this (change host name and port as appropriate) - test-netconnection hostname.domain.com -port 3389
    • Test succeeded. Also tested port 7273 with success.
  • Do you have any firewalls enabled on your Passwordstate web server? If so, you may need to allow access on Port 7273
    • For the time being, firewall is not on.

Thank you.

Share this post


Link to post
Share on other sites

HI ParrishK, 

 

Sorry we didn't respond back to this yesterday:( 

 

Could you please send us your log file from C:\inetpub\Passwordstate\hosts\gateway to our support email address (support@clickstudios.com.au)?  It might be worth zipping up the logs folder in that same directory and send it through to us.  Hopefully there is some sort of error in here which will lead us to a condition that is causing this to hang.

 

Regards,

Support.

Share this post


Link to post
Share on other sites
On 3/20/2018 at 10:24 AM, support said:

Try clicking the "Test SSL Certificate"

 

While our Browser Based Gateway is working, when our users do are yet to trust the SSL Cert and use the "Test SSL Certificate" link, they receive a page with nothing other than "Not Found" rather than the expected ssltest.html page.

Share this post


Link to post
Share on other sites

Hi Sarge,

 

From your desktop, can you do an open port test to your web server, and port 7273 - this is the default port the Gateway uses. Can you let us know if the port is open?

Regards

Click Studios

Share this post


Link to post
Share on other sites
10 hours ago, support said:

HI ParrishK, 

 

Sorry we didn't respond back to this yesterday:( 

 

Could you please send us your log file from C:\inetpub\Passwordstate\hosts\gateway to our support email address (support@clickstudios.com.au)?  It might be worth zipping up the logs folder in that same directory and send it through to us.  Hopefully there is some sort of error in here which will lead us to a condition that is causing this to hang.

 

Regards,

Support.

 

Just sent over the logs.

 

Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×