Jump to content
Emad

backup not working

Recommended Posts

Hi

Can you please help?  my initial backup is not working, getting an error "- Backup error detected - Object reference not set to an instance of an object."

I have followed the instructions in section "Backups and Upgrades".

I tried adding the backup account to the local admin group with no joy. Also tried my own admin account still did not work.

when I test it I get the error "Test Failed - please check if the Backup Path, UserName and Password are correct, that the account you specified has permissions to the backup share, and to copy file into this directory."

My production system works fine with no issues, please help.

Thanks

Share this post


Link to post
Share on other sites

Now I can't even upgrade the passwordstate, the error in

"

24/03/2020 18:18:45 - The following error occurred during preparing for an upgrade - Authentication Failed = Please check if the UserName and Password you have specified for Backups and Upgrades is correct.
24/03/2020 18:18:45 - The following error occurred during preparing for an upgrade - Object reference not set to an instance of an object. - Method = DownloadButton_Click

"

I removed the settings for "In-place upgrade Backups" which should ignore backup

Share this post


Link to post
Share on other sites

Hi

This system is my preproducion env & Current Build: V8.8 Build 8884   & want to upgrade Latest Build Available: V8.9 Build 8900.

are you saying it is abug & will be fixed soon?

My production sysytem Current Build: V8.7 Build 8765     Latest Build Available: V8.9 Build 8900

if I was to go a head & do manual upgrade, does that mean I will have to do the same for my production env, as it stands backup works fine but now not sure if I was to upgrade it.

Any thought please

Mnay thanks

Emad

Share this post


Link to post
Share on other sites

Hi Emad,

 

We use to have a bug a while back where it was still trying to perform a backup before an upgrade, even though you deselected the option. But that bug was fixed some time ago, and I just suggested a manual upgrade as I did not know what build of Passwordstate you were using.

 

So I do not believe our software is trying to do a backup here, but it does use that same backup account for performing the upgrade i.e. it needs permissions to perform the upgrade.

 

So you will need to investigate why you are seeing the error of "Authentication Failed = Please check if the UserName and Password you have specified for Backups and Upgrades is correct" - posiibly someone has reset this account's Password outside of Passwordstate.

Regards

Click Studios

Share this post


Link to post
Share on other sites

Hi Support

thank you, I raised support ticket id=20205727070336

I have checked the user permission & followed your guide, did not work.

I also added the backup domain account  & SQL service account to the admin group of both SQL & passwordsatet web front server, did not work.

I used my account to test backup did not work

 

regards

Emad

Share this post


Link to post
Share on other sites

Hi Emad,

 

When ever we replied to your emails, it would be returned as an unknown email address from outlook.com - which is very odd.

A lot of customers do use this feature for backups, so we can only presume you must have missed one of the settings, or group policy restrictions, mentioned in the Security Administrator's manual. Can you double check everything again? Maybe email as a screenshot of your backup settings screen to take a look at?

Regards

Click Studios

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...