Jump to content
Fabian Näf

Browser Extensions fills wrong fields

Recommended Posts

Hi guys,

 

I really like the new browser extension, it's such a great improvement! Excellent work!

 

I'd like to report a bug I'm experiencing (which I already had with the old extension).

 

Very often I'm using ServiceNow (Website). The main login page has two fields:

 

<input type="text" class="form-control" id="user_name" name="user_name" ...

and

<input type="password" id="user_password" name="user_password" ...

 

Filling this form works absolutely flawlessly. The Passwordstate record for this page has saved:

UserName Field ID:    user_name
Password Field ID:    user_password
 

But when I navigate to another page within ServiceNow to open an ServiceNow users record and edit it, the users username and password are getting overwritten by the extension. In this place, the autofilling is unintended as it overwrites current values and can lead to issues (user can't log in anymore).

Here the page looks like this:

<input type="text" id="sys_user.user_name" name="sys_user.user_name" a

and

<input id="sys_user.user_password" name="sys_user.user_password" type="password"

 

As you see, the id and name are containing the same, but are not equal....

 

Do you see any possibility to improve this?

 

All the best,

 

Fabian

 

Share this post


Link to post
Share on other sites

You can register here and request a developer test instance.

After you saved the main login credentials... In the menu you can then search for users and open the users table under "System and Security". There you can open a users record and will see that the User ID and Password field gets overwritten.

All the best,

 

Fabian

Share this post


Link to post
Share on other sites

Hi Fabian,

 

Quick update to say we will hopefully be releasing a new build soon that should fix this:)  Maybe 1 - 2 days.

 

Regards,

Support

Share this post


Link to post
Share on other sites

Hi Fabian,

 

Today we have released a new build of the Chrome browser extension (8812) which fixes a few more issues, which includes better form filling for your sites.  The extension should automatically update in your browser, and this doesn’t require you to upgrade Passwordstate at the same time, although we did release a new build of that today as well.

 

If you notice the new browser extension does not automatically fill in the credentials for you, this could be caused a few reasons:

 

  1. You have the URL saved as an ignored URL under either the global admin area, or your own personal preferences.  Screenshots of these areas below
  2. The field IDs have changed on the website, compared to what you have saved in Passwordstate.  Under these circumstances, if you manually select a credential from the icon overlay, this will fill the forms but it will also update the field IDs in Passwordstate, for all records that have the same URL that you have access to
  3. Some websites are built differently, and this can be for many reasons. In this case you can lodge the URL to us here at Click Studios, and we’ll do our best to fix it in a future build.  You can log the faulty URL directly from your Browser Extension now – Please see the third screenshot below

2019-10-21_9-36-40.png

 

2019-10-21_9-36-57.png

 

2019-10-21_9-34-50.png

 

 

Regards,

Support

Share this post


Link to post
Share on other sites

Hi Mark and Lee

 

Thank you very much for all the improvements. My issue with the user-records is resolved now. Instead of overwriting the user_name and user_password field I now get the overlay icon and nothing gets overwritten anymore. Thats great!

 

As I understand, the extension is working now in the way, that it doesn't automatically overwrite the fields, when they don't match exactly. Instead I'm getting the overlay icon and can select the credentials manually if I'd like to use the credentials from Passwordstate (e.g. when the field id has changed).

This perfectly works for me, when I click on the extensions icon and select a credentials from "Show matching Logins". But clicking on the overlay icon in the form itself has absolutely no effect. Shouldn't I get the popup to choose a credentials when clicking on the overlay icon?

 

All the best,

 

Fabian

Share this post


Link to post
Share on other sites

Hi Fabian,

 

Yes, clicking on the Icon Overlay should show you the list of saved logins, unless we are having issues with the specific site. Could you let us know the URL for it?

Thanks

Click Studios

Share this post


Link to post
Share on other sites

I noticed this on different websites, but I've also seen pages where I got the popup overlay. For sure it didn't work on ServiceNow sites.

You can get a test instance by registring on developer.service-now.com.

 

Share this post


Link to post
Share on other sites

I just bumped into another issue. When the form is on the very left side of the website, a part of the overlay popup is getting cut off. Here the mask of ServiceNow /login.do site.

 

image.png.e43f85f5598158f0947e819581481dce.png

 

The issue I mentioned above, that I dont get the overlay popup, is happening only on the user record in ServiceNow, but not on the login.do page. I just double checked that.

Share this post


Link to post
Share on other sites

I just figured out, that the overlay popup doesn't show up in the normal ServiceNow view, where the user record is loaded in an iframe on the right hand side of the page. But when you open the user record directly (I mean without the iframe), then I can click on the overlay icon and I get the overlay popup.

 

Working:

https://test1231.service-now.com/sys_user.do?sys_id=b824ce5bdbXXXXXXXXXXXXXX91c

 

Not Working:

https://test214.service-now.com/nav_to.do?uri=%2Fsys_user.do%3Fsys_id%3Db824ce5bdbaXXXXXXXXXba51d96191c

Share this post


Link to post
Share on other sites

Hi Fabian,

 

Thanks for this, but unfortunately we cannot really support iframes where the URL is different to the main site - as we do not have the iframe URL recorded, this is what causes the issues.

Regards

Click Studios

Share this post


Link to post
Share on other sites

Hi Mark&Lee

 

I truely understand that you don't support form filling within iframes. As I still have the workaround to choose a matching credential by using the extension icon it's totaly fine with me. 

 

But I need to mention, that the issue, that the overlay popup got cut off (see screenshot above) is not related to iframe. I think this is a general issue, when the form is on the very left side of a website.

 

All the best,

 

Fabian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×