Jump to content
Mark Bell

browser extension not filling fields

Recommended Posts

After the latest plugin update, there are some sites where it's not automatically filling the login fields.  The plugin recognizes the site because the number in the red box shows up and after I click "Show Matching Logins" (there's only one) and click the login, it will populate the fields.  The "Enable Auto-Fill" box is checked so I would expect those fields to populate automatically.

 

On another site, there's a gray Passwordstate box showing the number 2 (there are two logins for this site) in the username and password fields but when I click on it, nothing happens.

 

Any thoughts on what might be going on?

Share this post


Link to post
Share on other sites

Hello Mark,

 

Thanks for the information, and the only site that did not work for me was https://www.atfcu.org.

With the other sites, please try the following - try each step independantly, and let me know if they help. After doing each step, you will need to log out of your extension, and then back in (into Passwordstate), to pick up these changes.

  • Only record the base URL for the site i.e https://app.atera.com and not https://app.atera.com/Login#
  • On each of password records, click on the 'Browser Form Fields' tab, and clear the fields here
  • Or finally, try resetting the cache in Chrome

Can you let us know which one of these helps?

Regards

Click Studios

Share this post


Link to post
Share on other sites

Hi Mark,

 

We just figured out the issue with www.atfcu.org as well - they are using a nested iframe on this page, and the iframe points to the URL of https://onlinebanking.atfcu.org

 

If you update your URL in Passwordstate to this, then it should form fill okay. Please be aware that we do not really support nested iframes, but this does seem to be working now also.

Regards

Click Studios

Share this post


Link to post
Share on other sites
9 hours ago, support said:

Hi Mark,

 

We just figured out the issue with www.atfcu.org as well - they are using a nested iframe on this page, and the iframe points to the URL of https://onlinebanking.atfcu.org

 

If you update your URL in Passwordstate to this, then it should form fill okay. Please be aware that we do not really support nested iframes, but this does seem to be working now also.

Regards

Click Studios

Yes, I already had that as the URL.

Share this post


Link to post
Share on other sites

For the Atera site, I only have "app.atera.com" in the URL field.

 

Thinking something might be wrong with my Chrome installation, I uninstalled Chrome this morning, deleted all the Chrome folders under my profile folder, and did a fresh installation but it's still not working.  

 

I started thinking maybe there's something in my Chrome profile or one of the other extensions I'm using that's interfering so I went to another machine that's never had Chrome installed, installed it but did not log in to my Google account, installed and activated the Passwordstate plugin.  When I browsed to those sites, the same symptoms occurred.

 

As yet another test, I RDP'd to a terminal server with Chrome installed but is not logged in to my Google account, installed and activated the PWS plugin and the same symptoms occurred again.

 

The only common thing between all these computers is they're referencing the same Passwordstate server.  Could there possibly be something with the server that's causing the issue?  It didn't seem likely to me since the plugin was recognizing the sites and seeing there were credentials available but like I said, that's the only common link between all these computers.

 

What's so strange is the plugin had been working for all of these sites prior to the update to the latest build.  I was so pleased with it that I had deleted all of my saved credentials from Chrome and had just been using Passwordstate and the plugin but now... :-(

 

 

Share this post


Link to post
Share on other sites

Hi Mark,

That is very odd, as all those sites were working for me.

We are going to try and make some changes in the next build, as we've seen some different sites behave like this, so maybe we can just wait until that is available and try again?

Regards

Click Studios

Share this post


Link to post
Share on other sites

Hopefully some time next week Mark. Please be aware though, as we cannot replicate the issues you are seeing, the changes we are making could possibly not work - but let's hope they do.

Regards

Click Studios

Share this post


Link to post
Share on other sites

Hi Mark,

Thanks for the offer - we could possibly do this a little later today if possible - it's currently 7am here. Would you be available later?

Whilst we could witness what you're seeing, we may not be able to debug the issue without our own development environment - but at least we can witness it.

Regards

Click Studios

Share this post


Link to post
Share on other sites

It's 5:00 P.M. here now and I could be available later this evening.  Please e-mail me at the address in my profile, or send me a private message through the forum and let me know how you'd like to get access.

Share this post


Link to post
Share on other sites

Hi guys,

 

Yesterday I just started to experience the same for a certain website. The icon of the extension is showing, that there's a record, but it doesn't get filled in. Login/Logout of the extension was not helping to get it sorted.

As I remember right, on this page the extension was ask once for saving another credential and I think I clicked "Ignore". I haven't done any further investigations, as my issuing page is just temporary. I'm only guessing, that this could be related.

@Mark Bell Could you doublecheck, if this page is listed as ignored in your user preferences?

 

All the best,

 

Fabian

Share this post


Link to post
Share on other sites

Hi Mark,


Unfortunately in Chrome you cannot disable Auto-update. We could give you the source code for the previous version, but you would need to load this in Developer mode and then your users will be prompted every time they start their browser saying a developer extension is running.

We're are trying to fix this as quick as we can, but we hope you can appreciate that when we do not have access to the problem sites, it's very difficult for us. Saying that, we've found a couple of local sites ourselves which are not form filling, and we are working on fixing them now - hopefully it will fix it for you also.

Regards

Click Studios

Share this post


Link to post
Share on other sites

Hi All,

 

We've release build 8806 of the new Chrome Extension today, as well as Build 8806 for Passwordstate - you do not need to upgrade Passwordstate to use the new chrome extension build.

If you are still having issues with form-filling after upgrading, please check these things:

  • On your password record, please ensure the URL field is prefixed with https:// i.e store the URL as https://www.clickstudios.com.au and not just www.clickstudios.com.au
  • Ensure your URLs are not recorded as 'Ignored URLs' in Passwordstate. This can be done on the screens Preferences -> Browser Extensions tab, and Administration -> Browser Extension Settings, as per the screenshots below

If making any changes to data in Passwordstate, please log out of the extension, and then back into Passwordstate to pick up the change.

 

URLs1.png

URLs2.png

 

Regards

Click Studios

Share this post


Link to post
Share on other sites

Hi Guys


I just updated to 8806 and I did some testing. It seams like, that Passwordstate doesn't fill the form anymore when a website is configured as ignored website. I'm a bit supprised by this behavior, as the description says, that it would prevent the extension from prompting again for saving credentials. Now it seams like, that ignoring a website means, that the website is not going to be autofilled anymore.

 

All the best,

 

Fabian

Share this post


Link to post
Share on other sites

Hi Fabian,

Yes, that is correct - and sorry, we should update the documentation to reflect this. Or maybe we'll discuss with the team whether this should be changed or not.

 

To confirm, if you've already saved the credential, you should not be prompted a second time to save it - is this happening for you?

Regards

Click Studios

Share this post


Link to post
Share on other sites

Hi there 

 

Thanks for the fast reply! I personally would prefere the behavior as it is described in the documentations ;-)

 

No I havn't seen prompting again a second time.

 

All the best,

 

Fabian

Share this post


Link to post
Share on other sites

Thanks Fabian - we are discussing this internally, as we did change the behavior in the latest build.

We'll let you know once we have an update.

Regards

Click Studios

Share this post


Link to post
Share on other sites

Hi Everyone,

 

Today we have released a new build of the Chrome browser extension (8812) which fixes a few more issues, which includes better form filling for your sites.  The extension should automatically update in your browser, and this doesn’t require you to upgrade Passwordstate at the same time, although we did release a new build of that today as well.

 

If you notice the new browser extension does not automatically fill in the credentials for you, this could be caused a few reasons:

 

  1. You have the URL saved as an ignored URL under either the global admin area, or your own personal preferences.  Screenshots of these areas below
  2. The field IDs have changed on the website, compared to what you have saved in Passwordstate.  Under these circumstances, if you manually select a credential from the icon overlay, this will fill the forms but it will also update the field IDs in Passwordstate, for all records that have the same URL that you have access to
  3. Some websites are built differently, and this can be for many reasons. In this case you can lodge the URL to us here at Click Studios, and we’ll do our best to fix it in a future build.  You can log the faulty URL directly from your Browser Extension now – Please see the third screenshot below

2019-10-21_9-36-40.png

 

2019-10-21_9-36-57.png

 

2019-10-21_9-34-50.png

 

 

 

 

Regards,

Support

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×