Jump to content
Fabian Näf

Hosts: Can't find "host & remote session launcher"-Tab

Recommended Posts

Hi

 

As written in the manual under /help/usermanual/hosts__remote_session_launcher.htm, I should configure the remote session launcher under my user-preferences.

Unfortunately, I cant find the "host & Remote session launcer"-tab in my Preferences.

 

Best regards,

Fabian

Share this post


Link to post
Share on other sites

Hi Fabian,

With the User Manual, I think you might be picking up an old version of the html file, and we'll need to look into whether we can delete all of these during the next upgrade. In the User Manual, you need to look under the new 'Hosts' sections in the tree.

 

For your issue, I believe it might be caused by you not having permissions to the 'Remote Session Credentials Permissions' section on the System Settings screen - see below. Can you let us know if this is the issue - you might also want to review the permissions on all these other buttons as well.

 

sys1.png

Share this post


Link to post
Share on other sites

Hi

 

I just checked my "Remote Session Credential Permissions" and it's configured that all Users and Security Groups have access to Remote Session Credential Permissions.

 

I tried to use the Remote Session Launcher on two computers.

 

Computer 1

This computer has installed the old version before. As I understand during the installation of the new version, the old version should be removed. But this didn't worked (the old version was still listed in appizw.cpl). But this could also be related, because I did some changes in the PSLauncher.ps1 by myself.

When I click to "Launch" to connect to a computer by RDP, it prompts for entering username and password. When I look into %temp%\PSLauncher.log I found some errors:

Remote Session Launcher API Key not found for user.

 

Computer 2

This computer has no old version installed. I just installed the new version. But it doesn't work at all: When I clickt to "Launch" to connect to a computer by RDP nothing happens (also no log entry).

When I click to "Configure Browser" under "Install and Configure Remote Session Launcher" the popup opens and I got an error in %temp%\PSLauncher.log:

Remote Session Launcher API Key not found for user.

 

So I thought, that I would need to configure my API Launcher Key (as in older versions), but I couldn't found the tab for that anymore.

I did all my tests on Windows 10 with Chrome.

 

Best regards,

 

Fabian

Share this post


Link to post
Share on other sites

Hi Fabian,

 

There are two other conditions where this tab in Preferences would be hidden/enabled:

  • If you are Impersonating a User from the User Accounts screen (it will be disabled)
  • If you are logged in with a user account which belongs to a Site Location other than 'Internal' (it will be hidden)

Are either of these the case, as I've checked the code and these are the only 3 conditions where this tab can be hidden/disabled.

 

Regards

Click Studios

Share this post


Link to post
Share on other sites

Hi

 

I'm not impersonated and my user accounts belogs to the site location "Internal".

I just tested this with three different users, all are imported from AD and belong to the site "Internal". I don't have any other sites.

One of these three users was imported from after the upgrade to version 8 (don't know if this matters).

 

I can't find the tab "host & remote session launcher" with any of this users in the preferences of these users.

 

Best regards,

 

Fabian

Share this post


Link to post
Share on other sites

Hi Fabian,

Thanks very much for your patience with this, as we've been able to figure out the bug. Using SQL Server Management Studio, can you execute the following statement:


USE Passwordstate

INSERT [FeaturesACL] (Feature, SecurityGroupID, UserID) VALUES ('Remote Session Credentials', 0, 0)

 

This will grant all users access so they can see this tab, and during the next upgrade we will correct this bug properly.

Regards

Click Studios

Share this post


Link to post
Share on other sites

Hi 

 

Thanks a lot for your help!

After I inserted this record, I was able to configure my API Key for the Remote Session Launcher. Now everything works great!!

 

Best regards,

 

Fabian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×