Jump to content
PPISysAdmin

Browser Plugin problem

Recommended Posts

We are setting up our first Passwordstate server and are having problems getting the browser plugin to work. It turns white when I log into Passowrdstate, but if I go to any other web page it turns red.

Any suggestions of what to look at? I do have a case open, but the time difference between the US and Australia is slowing things down to a crawl.  

Share this post


Link to post
Share on other sites

Hi Randall,

Sorry for the email delays - normally the longest it should take for us to respond is 12 hours, which is pretty good for a software company :) We also do need to prioritise support for customers who have purchased support - we hope you understand.

We've done multiple testing on machines here, and cannot seem to reproduce this issue in Internet Explorer. Could you possibly trying installing the extension on another machine to see if you see the same results - hopefully it's something we can resolve, and not something specific to your environment i.e. maybe some group policy settings. Below are the normal troubleshooting steps we use for IE, and we do understand you've done a few of these already:

  • Clear your cache in IE (as you have made some changes to URL and SSL Cert)
  • Uninstall the extension, and make sure the registry key HKCU\Software\Passwordstate is deleted
  • Now re-install the extension (as an Admin) and try again
  • Check the registry key HKCU\Software\Passwordstate has been created and looks correct, also when you open another tab and the icon turns Red - this registry key must exist for the extension to work
  • Make sure you are using a trusted SSL certificate, and that cookies are allowed in IE
  • Make sure you do not have Passwordstate set as your default home page in IE - we've seen these symptoms a couple of times when this is set for other customers
  • And to see if there are any errors being reported at all, go to the the screen Administration -> Auditing, and filter on the 'Browser Extension' platform

Regards

Click Studios

 

Share this post


Link to post
Share on other sites

Thank you for the reply, I will see if I can find another PC to install it on. In the mean time I don't find an uninstall for the extension, (it's not in the Control Panel Programs and Features) what is the procedure to uninstall it? FYI removing the extension from Chrome and adding it back worked. So now the extension icon is white but it is not prompting me to select a credential, or fill in the credentials or add the credentials to Passwordstate. Can you tell a website that you know works with the extension to test against?

 

Edited by PPISysAdmin

Share this post


Link to post
Share on other sites

OK I have made more headway. The IE Extension works if you run IE as an Administrator. Close IE and run as a regular user and it behaves as before. Chrome is working fine as a regular user.

Share this post


Link to post
Share on other sites

Hi PPISysAdmin,

 

We've just tried testing this and unfortunately cannot replicate it in any of our environments.  It does sound like possibly there are some sort of restrictions on IE addons in your environment. With the install of the Internet Explorer extension, this should be showing up under Add/Remove Programs - can you please check again?

 

One good way to test this is to log into a machine with a user where there is bare minimum group policies applying.  I'm not sure if you have anything like this set up, but do you have any container/s specifically set up in AD with no group policies applying, for testing purposes?  The idea is to move the user and computer to this container temporarily, perform the test again and see what kind of behaviour you get?

 

Is this a possibility?

 

We have had other customers report also that they have deployed the IE extension to many non-admin users, and they have not reported the same issue you are seeing.

 

Thanks

Click Studios

Share this post


Link to post
Share on other sites

I have had this same issue. It's OK in Chrome, but IE11 is a fail, the only fix I found was to run IE11 in unprotected mode, hardly a secure option.

I tried using it on a PC with no GPO's applying, and it still exhibited the same issue

 

We are currently using the free 5 user version, having tried the trial version with a whole department but as it wont work with IE11, we had to put on hold, rolling it out any further.

I'd like to use it for the whole company, but if it wont work with IE11, then we'll have go elsewhere.

 

If useful, I can arrange a remote session with clickstudios to observe the issue?  I do need to either get this working or choose to try another product.

 

G

 

 

Share this post


Link to post
Share on other sites

Hi Glyn,

In our last email correspondence, you mentioned this was happening on one PC - based on your forum post, is this now happening on many PCs? Not sure if you had the chance to try our latest suggestions, but below are them again.

 

We could organise a Remote Session, but trying to troubleshoot IE issues like this is quite difficult, as you've found out, mainly because of the very old architecture of IE, and possible security settings in customer's environments. If you would still like to do this, can you contact us via our Support page, and we'll organise a time - https://www.clickstudios.com.au/support.aspx. If we do a remote session like this, we will need a PC that we can clear all IS settings and make various changes to try and troubleshoot the issue - so not your Director's PC :)

 

Does the Add-On show up in the IE Tool bar, or is it not visible at all?  If it is visible in the toolbar, is it white like my screenshot below?

 

ie1.png

 

If it is not visible in the toolbar, then can you go into the IE Settings -> Manage Add-Ons and enable it in here?  Screenshot show where I’m talking about)

 

ie2.png

 

Hopefully this is all you need to do, but if you absolutely need to do a clean uninstall, which luckily will not affect anything else on the machine, you can try these steps: 

  1. Remove the program from Add/Remove Programs
  2. If it exists, (which it shouldn’t), remove the C:\Program Files (x86)\Passwordstate IE Extension folder and all contents
  3. When logged in as your director, delete the HKCU/Software/PasswordState key
  4. Now install again using the latest source file from here:  http://www.clickstudios.com.au/downloads/PasswordstateIEExtension.msi

 

Regards

Click Studios

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×