Jump to content

Permission inherit on nested passwordlists/folders


Recommended Posts

When creating a nested passwordlist or folder, the permissions from the upper passwordlist is not inherited correctly.

 

We set a securitygroup with "Modify" rights on a list and let users from that list create folders and passwordlists below - but these only apply the creators permission, not for the securitygroup. 

I think i looked through all the settings, but couldn't enforce inheritage. Anything I could try or is it by design?

Build 8983

 

Regards Stefan

Link to post
Share on other sites

Hi Stefan

 

We have a couple of different permission models in our software.  The standard model is where you set permissions on the Password Lists, and those permissions will be sent up to any Folder.  

 

The second model is called the Propagating permissions model, where you set permissions on the top level folder, and those permissions filter down to all nested Folders and Password Lists.

 

Can you take a look at this video which  explains this in more detail, and hopefully this helps? https://www.youtube.com/watch?v=QBJE_xD185U

 

I think you'll need to convert your Permission Model over to the Propagating permissions Model, but if this doesn't help, please let me know.

 

Regards,

Support

Link to post
Share on other sites

Hi Stefan,

 

By default you cannot nest Password Lists beneath other Password Lists - you can only nest Password Lists beneath Folders. There is an option to allow this which can be enabled, but that option is being deprecated in version 9, as it causes confusion like you are seeing.

 

So if you are not using Folders, then you must apply permissions to every single Password List you see in the Passwords Navigation Tree.

I hope this clarifies.

 

**Edit** there is a bulk permissions feature to quickly add permissions to multiple lists at once, found under Administration -> Password List Options.


Regards

Click Studios

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...