Jump to content

immac

Members
  • Content Count

    9
  • Joined

  • Last visited

  1. Hi, I am troubleshooting an issue where authentication goes through infinite loop between POST and GET. It was working fine till the issue came up unexpectedly Is there any way to debug this issue on the Passwordstate side? POST URL is going to https://server.com/logins/saml/default.asp GET URL is https://test.onelogin.com/trust/saml2/http-post/sso/* On the passwordstate log file I can see that following URLs are getting referenced GET /default.aspx GET /logins/loginadan.aspx GET /logins/saml.aspx POST /logins/saml/default.aspx On the Onelogin side login is successful for the App. Any guidance is appreciated. Thanks in advance,
  2. Nevermind. I think I found the issue. Looks like under 'Allowed IP Ranges' I had it configured for SAML2 for the IPs outside of those ranges.
  3. Hi, We had a SAML2 setup with Onelogin. Suddenly it stopped working and seems to go through the SAML request loop. Now I wanted to disable the SAML2 and go back to using AD authentication. For some reason it seems it again tries to do the SAML. I went to the System Settings and changed the default authentication back to Manual AD Authentication. It works on the same machine where I have the passwordstate installed i.e. it can do AD authentication. But on the other remote machines it still tries to do the SAML2. Looking forward for some guidance. Thanks,
  4. Thanks for your feedback
  5. Besides the 'Windows Authentication' I also enabled the 'Anonymous Authentication' on the passwordstate site. It is now working as expected but I'm not sure about security implications with having 'Anonymous auth' enabled. We do have network/firewall to block other networks from accessing the site Any recommendations/suggestions?
  6. Let me post the screenshot shortly and try the various options in the URL In the mean time, can it be related with having the following option in the 'web.config' file <authentication mode="Windows" /> Thanks,
  7. Thanks for your response. No it looks like the prompt is coming from the Passwordstate only not the local browser. If I just click cancel it's showing the following message. Is there any way to get rid of this now that it's doing SAML2 through Onelogin You do not have permission to view this directory or page.
  8. Nevermind it is working now. I was using a different connector on the Onelogin. I used the 'SAML Test Connector (IdP w/attr)' now The problem I have is it's still promptly for User/Password. I don't want to save the user/password in the browser.
  9. We followed instructions for SAML2/Onelogin setup in the 'Security Manual' Getting the following error while doing the SAML2 authentication We are using V8.6 (Build 8679) Error Code = An X.509 encryption certificate for the local service provider hasn't been configured., StackTrace = at ComponentSpace.SAML2.InternalSAMLServiceProvider.GetLocalServiceProviderEncryptionCertificates() at ComponentSpace.SAML2.InternalSAMLServiceProvider.DecryptSAMLAssertion(Object samlAssertion) at ComponentSpace.SAML2.InternalSAMLServiceProvider.GetSAMLAssertion(SAMLResponse samlResponse, XmlElement samlResponseElement) at ComponentSpace.SAML2.InternalSAMLServiceProvider.ProcessSAMLResponse(XmlElement samlResponseElement, Boolean& isInResponseTo, String& authnContext, String& userName, SAMLAttribute[]& attributes) at ComponentSpace.SAML2.InternalSAMLServiceProvider.ReceiveSSO(HttpRequest httpRequest, Boolean& isInResponseTo, String& partnerIdP, String& authnContext, String& userName, SAMLAttribute[]& attributes, String& relayState) at logins_saml_default.ProcessSAMLAuthentication()
×
×
  • Create New...